Issues discovering the Ganglion on El Capitan: "init timeout error"

edited February 2017 in Ganglion
Hi all

I am having some issues discovering the Ganglion board over ble on a mac running El Capitan. I know that ble is supported on the laptop, but when I run the gui the board doesn't appear in the list.

I have tried restarting, and resetting the Ganglion but no luck - has anyone else had similar issues?

**UPDATE** I have tried an alternative method using the processing specific gui, which allows me to select the bluetooth port, but when I hit 'start system it tries to connect to the Ganglion but then throws an init timeout error.'



  • biomurphbiomurph Brooklyn, NY
    Are you still having issues connecting with the Ganglion?
    If so, can you try a different computer or update your OS? There may be issues with BLE and El Capitan.
  • Hi there, yes still having problems - to be honest other projects took priority so am back to looking at this.

    If I run something like lightblue on the macbook I can see the ganglion board, but the processing master demo won't connect with the same init timeout error. I then tried the bundled csr 4 dongle and set it as the default radio through hardware io tools but it still won't connect.

    I have just got hold of an odroid xu4 which can see the ganglion board with hci lescan in terminal but as I am having issues installing processing on it I may just have to roll my own interface somehow.
Sign In or Register to comment.