brainflow issue opening port [resolved]

edited June 18 in Cyton

Hi there,

I am currently trying to set up the Ultra-Cortex for conducting EEG-mindfulness experiments. While I have been successful in acquiring data using a custom Python script, I am having problmes difficulties using BrainFlow. Each time I run brainflow it gets stuck, here (please see below). And I was also wondering what type of data is the one I see when running the python script (does this data need to be transformed? I have been checking your documentation, but it is not clear for me. I really appreciate any help


[2024-06-17 17:28:26.478] [board_logger] [info] incoming json: {
"file": "",
"file_anc": "",
"file_aux": "",
"ip_address": "",
"ip_address_anc": "",
"ip_address_aux": "",
"ip_port": 0,
"ip_port_anc": 0,
"ip_port_aux": 0,
"ip_protocol": 0,
"mac_address": "",
"master_board": -100,
"other_info": "",
"serial_number": "",
"serial_port": "/dev/tty.usbserial-D200PUBZ",
"timeout": 0
[2024-06-17 17:28:26.478] [board_logger] [trace] Board object created 2
[2024-06-17 17:28:26.478] [board_logger] [info] opening port /dev/tty.usbserial-D200PXXX



  • I solved it, following the solution someone else provided after having the same problem: I was connecting to /dev/tty.usbserial-DXXX and the GUI was connecting to /dev/cu.usbserial-DXXX. Changing to cu. works perfectly

Sign In or Register to comment.