v5 GUI error "NoClassDefFoundError" [resolved with v6]

mocker26mocker26 oregon
edited February 21 in OpenBCI_GUI

After downloading the src and launching using the bash OpenBCI_GUI it sends an error "NoClassDefFoundError" in the jssc/SerialPortEventListener; I'm not sure why this is being thrown since I looked through the files to confirm that all the classes are defined, and all the files are there. Is there something I'm missing? I'm running on Linux Ubuntu 22.04 if that helps.

Comments

  • wjcroftwjcroft Mount Shasta, CA

    Is there some reason that you need to run the GUI from source? Have you tried the pre-built installer?

  • @wjcroft said:
    Is there some reason that you need to run the GUI from source? Have you tried the pre-built installer?

    I don't see a pre-built installer unless you're referring to the Linux GUI download on the downloads page. I'm assuming then to run bash OpenBCI_GUI that is inside the downloaded folder to configure and install, but I really don't know what I'm doing. That's where I'm getting this error from, even though it's exactly what I downloaded.

  • wjcroftwjcroft Mount Shasta, CA

    OK, I was confused by your mention in the initial post: "After downloading the src and launching...". I did not see that you were referring to the binary executable.

    You were downloading the zip file, which is the pre-built binary: "OpenBCI_GUI".

    Richard @retiutut, do you have any suggestions about the error he is getting on Ubuntu?

    Mocker can you paste a bit more on the error text you see, here so we can see it?

    William

  • retiututretiutut Louisiana, USA

    I will need to see the full console log to debug further. You can also try GUI v6 Beta https://github.com/OpenBCI/OpenBCI_GUI/releases/tag/v6.0.0-beta.1

  • mocker26mocker26 oregon
    edited February 20

    @wjcroft @retiutut,

    Error: A JNI error has occurred, please check your installation and try again Exception in thread "main" java.lang.NoclassDefFoundError: jssc/SerialPortEventListener
    at java. lang.ClassLoader. defineClass1 (Native Method)
    at java. lang.ClassLoader. defineClass(ClassLoader. java: 763)
    at java.security. SecureClassLoader.defineclass(SecureclassLoader.java:142) at java.net.URLClassLoader. defineclassURLClassLoader. java: 468) at java.net.URLClassLoader. access$100 (URLClassLoader. java: 74) at java.net.URLClassLoader$1.run(URLClassLoader. java: 369) at java.net.URLClassLoader$1.run(URLClassLoader. java: 363) at java.security.AccessController. doPrivileged(Native Method) at java.net. URLClassLoader. findClassURLClassLoader.java: 362) at java. lang.ClassLoader. loadClass(ClassLoader. java: 424) at sun.misc.Launcher$AppClassLoader. loadClass(Launcher. java: 349) at java. lang. ClassLoader. loadClass (ClassLoader. java: 357) at java. lang.Class.getDeclaredMethods0 (Native Method) at java. lang. Class .privateGetDeclaredMethods (Class. java: 2701) at java. lang.Class .privateGetMethodRecursive(Class. java: 3048) at java. lang.Class.getMethodo (Class. java:3018) at java. lang.Class.getMethod (Class. java: 1784)
    at sun. launcher. LauncherHelper. validateMainclass (LauncherHelper. java: 544) at sun. launcher. LauncherHelper.checkAndLoadMain(LauncherHelper•java:526)
    Caused by: java. lang. ClassNotFoundException: jssc. SerialPortEventListener 
    

    This is the entire error.

  • retiututretiutut Louisiana, USA

    I do actually need to see the entire log, not just the error.

  • @retiutut I'm not sure what you mean by the entire log? I just retried it from opening my computer again and it produced the same error. What exactly do you need to see?

  • wjcroftwjcroft Mount Shasta, CA

    I think he may be referring to the Console Log, as shown in the Troubleshooting doc,

    https://docs.openbci.com/Troubleshooting/GUI_Troubleshooting/

    However your error is happening as the GUI is loading, so that feature is not available.

    Have you tried the GUI v6 beta that Richard mentioned?

  • Thank you guys, the GUI v6 beta works.

  • retiututretiutut Louisiana, USA

    Awesome! Happy hacking!

Sign In or Register to comment.