"Networking Serial, Focus error - null" [resolved]

edited February 16 in OpenBCI_GUI

I am trying to follow this instructable:

https://instructables.com/Send-Focus-Data-From-OpenBCI-GUI-to-Arduino/

to send focus data from the GUI over serial connection to an Arduino. I open up the GUI as admin using "synthetic" data , connect the Arduino my computer with usb on COM5, and set up the focus and networking widgets. The networking widget is set to COM5 as well, with the correct baud rate.

The issue is that even once I click "start serial stream," the Arduino doesn't register any incoming data. In the console it says "Networking Serial, Focus error - null". Serial.available() is always a 0. Has anyone had this problem or know how to fix it?

Operating System and Version
Windows 11 23H2 22631.3155
GUI Version
v5.2.2

Are you running the downloaded app or from Processing/VSCode?
The downloaded app.

Type of OpenBCI Board
Cyton+Daisy

Comments

  • wjcroftwjcroft Mount Shasta, CA

    Hi Rhys,

    I'm mentioning Richard @retiutut (the author of both the GUI and the Instructables page) to see if he has any insights or debugging tips on the console log message you mentioned, "Networking Serial, Focus error - null".

    Are you sure the COM port is setup as you expect. Can you verify that with your Windows Device Manager and a serial Terminal emulator app?

    William

  • Hi, thanks for replying. I solved it, I had the serial monitor open in the Arduino IDE which stopped the GUI from being able to communicate with it. Clearly, I'm new to this.

  • retiututretiutut Louisiana, USA

    It's ok @rhys151! Glad you figured it out. We're all learning and growing. B)

Sign In or Register to comment.