problems with Ganglion/Cyton 'clone' boards

MathiasAndersenMathiasAndersen Denmark
edited September 2023 in Other Platforms

Hey everyone,
I was speculating whether or not (cheaper) chinese alternatives are comparable in quality and accuracy to the products of OpenBCI. Does anyone have information on this? It is hard to find information on how these alternatives actually perform. On a sidenote: Does anyone know viable 8 or 16 channel alternatives that are cheaper than the products of OpenBCI?

Thanks in advance

Comments

  • wjcroftwjcroft Mount Shasta, CA

    NO.

    They have multiple hardware bugs. These have been reported by users both here on the Forum and in customer support.

    A primary reason is that these boards lack the RFduino radio modules, and instead use a modified Wifi Shield. Wifi Shield has been temporarily withdrawn from the OpenBCI Shop, because it needs engineering changes. The Chinese clones have not solved those issues.

  • edited September 2023

    I am kind of stuck with a Chinese clone using the combo WIFI/daisy board. I bought it, and am not sure if I can return it.
    It's one with three boards, a battery board then a Cyton V3, and on top, a combo WIFI/Daisy board.

    It sounds like you may be familiar with the problems. Would you be willing to give any specifics on what the hardware bugs are with the Chinese clones?

    Are there software incompatibilities with the GUI? I think I have the setup right, but I cant get it to talk to the OpenBCI GUI program. Maybe the missing RFduino module is causing a problem?

    For debugging, I hardwired to the serial port on the Cyton with a FTDI chip USB serial cable/putty. All of the Cyton hardware is working. I can issue commands, configure hardware, stream to the SD card, etc. with Putty. The code is up to date - 3.1.2. It was pretty easy to figure out the command syntax from the source code on GitHub.

    I just can't get it to communicate with OpenBCI GUI via WIFI. I confirmed that the WIFI module is working. I am able to connect to my WIFI network, assign an IP, pull up the WIFI host page in my browser, etc. I am drilling into the code to see why it won't talk, but if you know something, I would appreciate you sharing.

    BTW, I have decades of professional experience solving analog problems like ground loops, noise, EMC, etc. Mods should not be too much of an issue for me.

  • wjcroftwjcroft Mount Shasta, CA

    re: stuck with clone

    Your only solution to the Wifi connectivity issues is to work with the (flakey) manufacturer. It appears they have screwed up the Wifi firmware.

    re: Wifi Shield issues with packet loss / distortion with Cyton

    This is documented extensively on other threads and is NOT what you describe in your comment above. The distortion causes occasional lost / distorted / noise signals. Your situation is not seeing any Wifi connectivity whatsoever. TWO separate issues.

    https://openbci.com/forum/index.php?p=/discussion/2108/measured-shield-regulated-3-3v-supply-has-6v-dip-at-1-second-intervals-with-resonant-ringing

    If you read through that thread above, in actuality, the issue is NOT with the shield power supply stability, because everything works fine when the shield is paired with Ganglion. The issue is more likely some way the Cyton firmware is stressing the Wifi hardware module (ESP8266), and causing the strongly increased current demand. So in other words, it cannot be fixed by 'band-aid' solutions involving extra power supply filtering capacitors. The clone manufacturers have not solved the root issue with the Cyton firmware stressing the ESP module.

    Regards,

  • I will try contacting the seller, but that is probably not going to resolve anything quickly.

    In the mean time, I would appreciate any insight that may be available from this forum's users.
    That's the reason for this forum to exist right?
    Would it be better for me to start a new thread to get broader exposure?

    For sure, my current issue is rooted in WIFI not operating properly somehow. The thread you kindly referenced is a completely different issue.

    The WIFI firmware is 2.0.5, Cyton firmware is 3.1.2. These should be compatible with the ESP-12S module and the GUI right?
    I am not sure what you mean when you say " It appears they have screwed up the Wifi firmware".
    The 192.168.4.1 webpage looks standard "push the world" , and reports V2.0.5
    The manufacturer should just flash the ESP-12S with the 2.0.5 binary and it should work right?

    As near as I can tell, all of the I/O is configured and connected correctly, and the DAISY/WIFI hardware is seeing the Cyton's commands. Both TI 1299 chips and the accelerometer are clearly working- I can see appropriate date being written to the SD card when I manually command the Cyton to stream to the SD card using the serial cable with putty.
    When I put a scope on the SPI for the ESP-12S, I see valid SPI data synchronous with it's slave select.
    When I command "WIFI attach", SPI data to the ESP-12S starts.
    When I command "WIFI detach", SPI data to the ESP-12S stops.
    When I put a scope on the SPI for the Daisy's ADS1299, I see valid SPI data synchronous with it's slave select during acquisition.

  • wjcroftwjcroft Mount Shasta, CA

    @jenelson said:
    ...
    Would it be better for me to start a new thread to get broader exposure?

    No, the current thread title describes your issue.

    Multiple clone board users have reported unsolvable issues with the operation of their boards. There also appear to be more than one manufacturer of the clones. So issues likely differ between manufacturers. These boards are entirely unsupported by OpenBCI staff. As the Wifi Shield design has been withdrawn pending (possible) future needed engineering changes. Especially regarding the so called 'power supply' caused distortions and lossage. (As previously mentioned this is likely NOT because of the voltage regulation / power supply filtering capacitor, but that Cyton firmware is stressing out the ESP8266 wifi module. Ganglion does fine in that configuration.)

    I do seem to recall one user who had the three board stack you mention. He initially had many problems. But I heard later that he got it partially working. If 'partially' is good enough for you. ;-)

    https://openbci.com/forum/index.php?p=/discussion/3502/cyton-wifi-packet-loss-noise-issues

    Mentioning @stellarpower, you might be able to help @jenelson ? If your board manufacturers are the same.

    William

  • stellarpowerstellarpower Scotland
    edited September 2023

    I cant get it to talk to the OpenBCI GUI program. Maybe the missing RFduino module is causing a problem?

    What exactly is it you're seeing?

    FYI, to connect to the wireless, you need to remove the layer below. Just going from memory, but if yours has those three layers like this:
    like this
    I needed to unscrew the standoffs, remove the top layer, remove the middle layer, then re-connect the top layer - so in essence, you're just powering the wifi shield. Then you need to connect it to the wireless through a web browser. Once complete, you can power it off again, and reconnect the middle layer back to normal. Then that should allow it to send data.

    Otherwise, afraid I'm not much of an electrical engineer, so I don't know anything about how the SPI is laid out.

    Personally, I had problems with artefacts, unless I had really low impedance on my electrodes. Afraid I can't comment in enormous detail, as I only bought the off-brand Cyton to tide me over a few months whilst my FreeEEG32 was experiencing supply-chain delays; it's more or less been sat unused since the latter has arrived. For anyone on a budget, it offers 32 channels for $250 US, and just uses a serial port over USB for communication, so that simplifies things re latency and any issues with connectivity over the air. So now they're shipping, this is probably the better option over an off-brand Cyton - even second-hand, that cost me more for fewer channels.

  • Sorry I took so long to get back to this, but busy.

    That picture looks exactly like the stack I have. Sounds like you were able to at least get your board talking to the GUI. My board, no dice.

    I have performed the steps to connect the WIFI https://docs.openbci.com/GettingStarted/Boards/WiFiGS/
    I tried both "direct mode" and "station mode" mentioned in the document.

    I was easily able to connect a web browser to the WIFI in "direct mode" at 192.168.4.1 using a direct WIFI connection to my workstation's wireless adapter.

    With the WIFI board unstacked and powered from battery, I was able "click to Configure Wifi" to connect to my WIFI access point in "station mode" and save an IP address. I got the 4 blinks, 10 sec wait, then 2 blinks LED pattern. My WIFI AP DHCP assigned 192.168.0.111. I set this to Static for now in my router.

    This all seems to be working.

    It sounds like I am having a different experience than you had going forward though.
    My experience connecting to the WIFI Shield with the GUI is a bit flakey. Here is how it goes:

    I launch the OPENBCI GUI 5.2.1.

    When I select CYTON(live) -> Wifi (from Wifi Shield) -> DYNAMIC IP -> START SEARCH, the board is not found.
    I press "START SESSION" and I get a notification in yellow at the bottom of the GUI pane:
    "No Wifi Shield selected. Please select your Wifi Shield and retry system initiation."
    Obviously, search is not finding the board with DYNAMIC IP selected.

    Next, I select CYTON(live) -> Wifi (from Wifi Shield) -> STATIC IP -> .
    I press "START SESSION" and I get a notification in red at the bottom of the GUI pane:
    "Failed to initialize board. Please check that the board is on and has power. See Console Log for more details."
    Interestingly, if I subsequently press the "DYNAMIC IP" button at this point, My board IP is shown in the GUI
    I get generally the same result with "direct mode" and "station mode" Wifi.

    I am tentatively thinking that the GUI is actually finding the WIFI shield module, but it is unable actually to access features of the Cyton board hardware over Wifi.

    Given that I have confirmed previously that the Cyton hardware SPI interface looks OK on my oscilloscope, and that the I can connect with a hardware serial cable to the Cyton, I suspect that the Cyton firmware 3.1.2 is running, but not setting up the Wifi module V2.0.5 firmware properly.

    Thoughts, anyone?

    Do you by any chance know what versions of OpenBCU GUI, Cyton firmware, and Wifi firmware are running on your module?

    BTW, FreeEEG32 looks interesting. It seems to still be under development though. Is yours working well?
    It looks like a real bargain at only $250 for 32 channels. At $250, I may just order one to play around with.
    I would still prefer wireless operation though, so I will still try to get my module working.

  • Sorry, I never got notified about this. I can;t reply properly now, but I could look up the GUI version etc.

    Maybe you could try just connecting through BrainFlow. If you want a graphical plot, it's easy enough to connect a dummy classifier using Neuromore Studio - you just need. Alternatively there are some python scripts hanging around that connect BrainFlow and a pretty crude plot widget. I was hoping to write an application some day that would do all of this in one, without needing a mess of hacky scripts.

    The FreeEEG32 is working well. The way the inputs are managed is a bit different, there's no common reference, each channel is just a positive and negative pair, there's no SRB. The amplifier's common mode also has a pin for noise-cancelling, and then you just have a 3.3V total swing in which you can work. I know development was long, it's really just a couple of guys, and they got hit badly by supply issues, CrowdSupply's own staffing issues, and the war in Ukraine. The one managing shipping basically had to absorb a lot of the cost personally. But I agree, it is good value, and I know FreeEEG16 is already underway and they have plans in the works for something like an 8-channel bluetooth wearable. Another person is speaking with some academics about getting the board approved for use as comparable against a BioSemi. It is wired, but at the same time, just appearing as a serial console makes life easier, and is about the lowest-latency option. I know it has also been used over fibre optic, to prevent the noise problems coming across the USB data line. I was interested in the possibility of plugging it into an android phone using an OTG cable, and then using that to send the data over the air. IDK how it would affect timing, and there would be a zoo of hardware and software. On the flip side, it makes sense to keep the specialised hardware as simple as possible, and exploit the highly sophisticated all-in-one devices we all have in our pockets, that are also battery powered and can connect onto an infrastructure wifi network in e.g. an office, rather than push this onto the EEG itself. IF i ever end up exploring this I can let you know.

    Remind me some time when I am less busy and I;ll check back and see if I can write down what I had to do to connect. USing static IP definitely helped, sometimes my board was reachable but the GUI couldn't see it. But brainflow seems a simpler starting point.

  • Well, I have it working over an isolated serial connection, and that's good enough for now. Actually, low latency is important for my application, so I'll just stick with the hardwired option for the time being. I do want to get the wireless working eventually though.

    This is just my educated guess, but the issues seem to be with firmware incompatibility between wifi module on the daisy combo and the cyton clone. All of the interfaces seem to be operating, and the devices appear to be connected properly. Also, the OpenBCI GUI is not talking to the wired serial port, so some compatibility issues here too. Maybe they require the dongle hardware instead of the generic FTDI chip USB serial cable I am using? anyway, not important now.

    Getting the wifi firmware on Github to compile is also problematic under Arduino.

    I would pass on some advice - I wont buy anything expensive from Aliexpress again. There does not seem to be any way to get a refund/exchange/support beyond delivery issues. If you are buying cheap, simple stuff, they are OK, expensive or complex stuff - risky. I am not convinced that Aliexpress are actually delivering functional firmware as advertised for this iteration of product.

    I have not given up, but wireless operation is on the back burner for now.

  • Are you seeing the FreeEEG32 on AliExpress? Or you mean your Cyton? I got mine second-hand on eBay to tide me over myself; the FreeEEG32 through CrowdSupply, although was in direct contact with the project maintainers. Again, as much as I agree it's convenient, the USB serial option does simplify life ????

    Agree on the latency. Most protocols I have seen have quite a large FFT window, and from what I have read, latency is important. I am moving to wavelet transforms for this reason, so I can give instant feedback and still accurately resolve delta.

Sign In or Register to comment.