Flashing Cyton Radio with Linux

edited January 2 in Cyton

Hi!
I'm trying to flash a Cyton V3-32. It doesn't work and I highly suspect it to have been re-programmed maybe with custom firmwares.
I use Linux (Mint 21).

I achieved the following steps with these results:

Setting up the system:

  • 1.I installed Arduino IDE 1.5.8 BETA
  • 2 3 4 installed the files into Arduino IDE

About the Note for Linux users:
I created a text file RFDLoader with the following:

#!/bin/bash
wine /home/raphael/Logiciels/arduino-1.5.8/hardware/arduino/RFduino/RFDLoader.exe /dev/ttyUSB0

I selected RFduino card, port, and tried to flash, but get the following error:

RFDLoader v1.2
Copyright (c) 2013, RF Digital Corp.
All rights reserved.

syntax: RFDLoader [-q] [-v] <port> <ihex_file>
  -q = quiet
  -f = fast (no verify)

Where is the ihex file?

Comments

  • wjcroftwjcroft Mount Shasta, CA

    Please do not reflash the firmware unless you are instructed to do so by customer service. Send an email to (contact at openbci.com) and ask how to proceed. How did you conclude that the issue is bad firmware? When was this purchased?

    William

  • Thank you wjcroft,
    I don't know when it was purchased.
    When I tried for first time, Cyton Device was not working at all, no light, not connecting with GUI. After flashing it, the led is lit when on and I can Start a Session, but auto-connect and manual-connect doesn't work, and the signals in the session are buggy: packets lost, channels with saturated signal sometimes and then no data at all, impossible to read a coherent impedance, etc...

  • wjcroftwjcroft Mount Shasta, CA

    Go ahead and email customer support.

  • Ok, thank you.

Sign In or Register to comment.