Daisy board not recognized, soldering issues?

edited April 2015 in Cyton
Hi
I have a problem on using OpenBCI GUI 16 channels.
When I using only 8 channels It works however when I connected the daisy module and selected 16 channels It doesn't work.
I was using the live mode and when I selected 16 channels the "channel count (8)" correctly change into "channel count(16)"
however when I selected start system it would change into "channel count (8)" and enter live mode.
When I clicked "Start Data Stream" button,. I can't see any signals
Does anybody successfully using OpenBCI GUI in 16 channels?

Comments

  • Hello,

    The first time I tried to setup the daisy module there was faulty soldering and it wasn't detected by the main board. Check in the console output that the board detects the daisy module. Well, I *think* this information is present in the console output of the Processing GUI, but I'm not sure anymore. It is the case at least with the python scripts -- which I know better. https://github.com/OpenBCI/OpenBCI_Python
  • biomurphbiomurph Brooklyn, NY
    @Gary,
    We have a few 16 channel setups here in our lab, and have not had any difficulty in getting them to behave.
    Can you reply with some photos and more description of your problem?
  • I had the same problem. It could only recognize the main 8 channel module (which works just fine). It seemed to me that the OpenBCI GUI did not succeed to connect. After I read this conversation I tried processing. BUT!! This time the main module's blue light did not even turn on when I connected the main module to the daisy module. It works with the main 8 channel module. 

    Has anyone any clue? I think it is a matter of hardware. Another clue...I've seen that in one of the pins on top of the daisy module there are two pins that are soldered together...May it be the problem?

    Thank you for any clue or indication... I have the daisy module and i can not reach the 16 channel...which is frustrating. 

    Ramón.
  • Hi,

    I am encountering same problems when I attached daisy module.
    I checked the soldering 4-5 times using Multimeter and it shows all connected.

    I've tried using Processing-openBCI-GUI (Windows) as well as python-interface(LINUX).
    Processing-openBCI-GUI : After selecting 16 channels, it displays "no daisy to attach" and switch back to 8 channel system by itself
    Python-interface(LINUX) : Used commands C and D (ScreenShot attached), same problem

    Is there any other way to access any pin/port of Daisy module so that I can check if its even connected or not?
  • Hi,

    I had already solved this problem by soldered the board again
  • I saw the above posts in which people tried to resolder and tested, I tried same 2-3 time but didn't work :(
  • biomurphbiomurph Brooklyn, NY
    @meagmohit,
    each of the Daisy modules were tested after the rework that we did here in house.
    it's not likely that you damaged it during soldering, but it does seem that it is not working correctly.

    the main board goes through a process to find the daisy, and if it says it can't find it, then it truely can't communicate with the Daisy.

    we are currently out of stock on the Daisies. Expecting to have more in about a month, at which time we would be able to do an exchange.

    please email contact-at-openbci-dotcom and that will get you into our customer support.

  • @biomurph Thanks for your reply.

    I was trying to figure out the problem and saw a defect(might be) in hardware. I am attaching a pic of my daisy module here.

    I noticed some problem in ADS1299 connections near C8/C-10 pins in daisy module. Its not present in ADS1299 of main board or even pics of daisy module on openBCI website. Could it be a problem that main board is not able to smell daisy?

    I can give it a shot if I can repair my daisy module. If not, I will request an exchange. 
    Thanks again!
    Mohit
  • It looks like the Daisy board may be damaged, likely from the extra soldering. It appears to have caused the solder to overflow between ADS1299 pins.

    In Image1, I see overflow pins 21 and 22 on the ADS1299. The same pins are bridged on my 8-bit BCI. Coincidentally, these are both 5V supplies for the analog circuitry. This may have been an intentional bridge.

    There is also overflow between pins 52 and 53. Pin 52 is the digital ground and Pin 53 is the master clock select. These should definitely NOT be bridged.

    Finally, there is a bridge between 57 and 58, both are the grounds for the analog circuitry. But, 58 is the charge-pump analog ground. Pretty sure these should not be bridged.

    I'd also be concerned about Capacitor 9 (C9). Looks like it good have been damaged.

    The BCI unit itself looks fine. From Image2, I definitely see solder overflow between leads on the ADS1299 between pins 21 and 22. Coincidentally, these are both 5V analog supplies so it shouldn't be an issue. There is the same overflow in Image 1. My personal unit has similar overflow, so I wonder if this was intentional.

    Also in Image2, I see overflow between pins 57 and 58. I do not have this bridging on my own unit. Again, these are both analog ground pins, but one is for the the charge pump. I am not sure if bridging would have a detrimental effect on performance.
  • biomurphbiomurph Brooklyn, NY
    Please take a look at this post


    The Daisies were all reworked in the area that you are referring to.
    It may be that the problem stems from that area. 
    As I mentioned, each reworked Daisy was put through a test to see if it could be identified and talked to.

Sign In or Register to comment.