Cyton connected but no data stream

gloglo Toronto, Canada

Hi all,
The dongle and cyton are successfully connected -> session started successfully -> but when I click the start streaming button nothing changes. I have used the same dongle to stream data from another cyton board and it works. The batteries are new.

I have been plugging in the dongle, and then powering the board on as required. The blue led is on for both the dongle and the cyton.
When I check the gui to show packets, the expected packets is zero.

Pairing Success

Session started

Streaming started

No packets

Picture of board and dongle

Comments

  • wjcroftwjcroft Mount Shasta, CA
    edited August 24

    Glo, hi.

    I have used the same dongle to stream data from another cyton board and it works.

    This implies that both Cyton's and dongles are set to the same radio channel. Can cause confusion if you ever try using both Cyton's at the same time. May or may not be related to the issue you are seeing. When did you purchase these?

    A first thing to try is the AUTOSCAN feature with the broken Cyton and dongle. Be sure the working Cyton and it's dongle are turned off / unplugged. Expand section 5 with the arrow.

    https://docs.openbci.com/GettingStarted/Boards/CytonGS/#5-optional-settings

    William

  • gloglo Toronto, Canada

    Hi William,

    Thanks, yup so I make sure that the working cyton and dongle were both turned off, and I also did try Autoscan (see first image in original post) it says that the "cyton and dongle are paired" and "cyton successfully connected to COM6" and the session starts successfully, but I still see no signal.

    The not working cyton/dongle was purchased in (2021).

    Thanks,

  • wjcroftwjcroft Mount Shasta, CA

    Does the 'Change channel' button work? (Pick a different channel than your other Cyton. 'System Status' should show the current channel.) If channel changing works, it means the two RFduinos (dongle and mainboard) are functional. If that is the case, it's possible your mainboard PIC32 firmware glitched. You can try reloading here:

    https://docs.openbci.com/Cyton/CytonProgram/

  • wjcroftwjcroft Mount Shasta, CA

    Use adhesive tape label to put the new channel numbers on each pair of dongle+Cyton, to avoid any future mixups.

  • gloglo Toronto, Canada

    Hi William,

    The change channels does work. The gui froze the first time so I restarted the gui, but I saw from system status channel was changed. Just in case, I changed channels again and it didn't freeze this time and the channel changed successfully according to system status.

    So then I reloaded the firmware just now. The first time I got the "program flash failed" and the main board LED kept flashing.

    So I moved the board closer and the tried again. This time the flash said "done", but I got the "read page failed" error in the verify step. The main board LED did stop flashing though so as this is an expected error I tried the gui again. Still no data stream.

    Will do with the tape label.
    Thanks!

  • wjcroftwjcroft Mount Shasta, CA

    but I got the "read page failed" error in the verify step. The main board LED did stop flashing though so as this is an expected error I tried the gui again. Still no data stream.

    Um, wait, can you point to where the instructions say that " 'read page failed' in the verify step" is acceptable? Are you sure you have a valid upload?

  • gloglo Toronto, Canada
    edited August 24

    In the link that you sent https://docs.openbci.com/Cyton/CytonProgram/

    -> "Note: occasionally, you may see the error message in the screenshot below. You can ignore this. As long as Program flash: ...................................#################################### done appears, 99 out of 100 times your firmware uploaded correctly. If your board doesn't appear to be working in the GUI (or other software), simply try re-uploading the firmware."

    I get the same screenshot as under that note^ and I'm hoping that this means I have a valid upload. Otherwise I've tried reuploading several times and I just get this same message. Is there something else I can try to see if I have a valid upload?

  • wjcroftwjcroft Mount Shasta, CA
    edited August 25

    Hmm, it does say that this "read page failed" occurs only 'occasionally', not every time. But you are seeing it every time.

    It does sound like something on the board has failed solidly and reflash is not helping. Have you tried emailing contact at openbci.com ? I'm unclear on the warranty period, when was this board purchased in 2021? How long did it function correctly before the failure? You might be aware that static discharges (if contacting board traces) can sometimes glitch components. The input pins are static protected, but not the exposed metal leads and traces on the board. Static discharge happens more typically in cold / dry environments. From the Cyton shop page:

    Evaluation Board/Kit Important Notice: OpenBCI, Inc. provides the enclosed product(s) under the following conditions: This evaluation board/kit is intended for use for ENGINEERING DEVELOPMENT, DEMONSTRATION, OR EVALUATION PURPOSES ONLY and is not considered by OpenBCI, Inc. to be a finished end-product fit for general consumer use. Persons handling the product(s) must have electronics training and observe good engineering practice standards. As such, the goods being provided are not intended to be complete in terms of required design-, marketing-, and/or manufacturing-related protective considerations, including product safety and environmental measures typically found in end products that incorporate such semiconductor components or circuit boards. This evaluation board/kit does not fall within the scope of the European Union directives regarding electromagnetic compatibility, restricted substances (RoHS), recycling (WEEE), FCC, CE or UL, and therefore may not meet the technical requirements of these directives or other related directives.

    William

  • gloglo Toronto, Canada

    okay thank you I will try that

Sign In or Register to comment.