abnormal Ganglion 1 Hz ramp ? [resolved with reflash]

xcorrxcorr Montreal
edited August 2021 in Ganglion

Hey gang,
I'm doing a quick sanity check on the Ganglion with a 3-lead EKG. I have a strange 1Hz ramp-like signal on channel 1. This is a very old Ganglion board that originally came with a CSR dongle - I bought the newer kind from the OpenBCI store recently after losing the original. I'm wondering whether it's not some issue with this newer Bluetooth dongle and the old firmware that's on this Ganglion board (which I can't upgrade right now, per this thread). Have you seen this? I've tried on Windows and Ubuntu and the results are similar.



  • wjcroftwjcroft Mount Shasta, CA

    Patrick, hi.

    Is this Ganglion running the originally manufactured firmware? I note on another thread you are trying upload code to a Ganglion. Assuming this board has default firmware.

    See this related thread on the 1 Hz 'sawtooth' pattern seen on occasion:


    What electrode setup are you using? If there is a galvanic / battery effect going on with your channel 1 electrodes, that could shoot through the max voltage that the compression algorithm handles. Hence resetting every second (every 200 samples) when the compression algorithm goes back to zero.


    A test that can be done with any EEG amp, is to use a glob of paste to connect the channel in question, reference, and ground. That should result in a trace close to zero microvolts.


  • wjcroftwjcroft Mount Shasta, CA

    You did not say how the board performs with your ECG usage. With any ECG, EEG, EMG situation, you only should look at results with the channels are connected to the subject. Channels that are free floating / not connected, can produce random noise, weird signals, etc. Unconnected channels are more subject to picking up ambient EMF noise from other equipment in the area.

  • xcorrxcorr Montreal

    It's still the stock firmware that came with it. The ECG signal you see at the top (channel 1) is with the 3-lead montage. I've also attempted to do EMG with this board but I can't see a signal.
    I did successfully test this board circa 2017, with both EMG and EKG, so I'm thinking that something changed between now and then - either it's the bluetooth dongle, some software incompatibility, or the board received a static discharge at some point that bricked it.

  • wjcroftwjcroft Mount Shasta, CA
    edited August 2021

    Did you try the paste glob test I mentioned, on each channel? It's possible that static discharged could have fried channel 1. Nothing in the BLED112 dongle can affect any of this. Any failures would be on the Ganglion board itself or electrodes. Are channels 2,3,4 free floating? As mentioned, free floating channels produce unpredictable noise.

    If you are just doing ECG on one channel, are you saying ALL FOUR channels demonstrate the same ramp pattern? If that is the case, then it might well be a firmware glitch that could be repaired with a re-flash.

  • wjcroftwjcroft Mount Shasta, CA

    The ECG signal you see at the top (channel 1) is with the 3-lead montage. I've also attempted to do EMG with this board but I can't see a signal.

    What electrodes are you using? As I mentioned, for example if you are using gold cups, and one cup has a chip in the gold plate, that will cause a galvanic battery effect. Because under the gold plate, is tin metal. Best case with ECG is using the foam stick on's, which are single use. These use silver chloride electrodes inside.

  • xcorrxcorr Montreal

    I tried every channel, with the switches both in both the up and down (common ref vs. individual ref) positions, with similar results. Screenshot is from AgCl sticky foam electrodes, but I've also tried gold cup with paste with similar results.

  • wjcroftwjcroft Mount Shasta, CA

    If you are seeing the same ramp on every channel, using the foam electrodes, then something is really screwed up on the Ganglion mainboard. Could be a static discharge caused a fried board, or possibly a glitched flash memory. If this is a first generation Ganglion, then OTA flashing will not work, and you need:


    After which, the OTA will work.

  • xcorrxcorr Montreal

    That was definitely what I intend to do, and I have an FTDI friend and a cap to do so - I will try your flashing instructions and see if that helps.

  • retiututretiutut Louisiana, USA
    edited August 2021

    Great use of the "Auto" scaling in TimeSeries so that this is clearly visible in the screenshot. It does indeed suggest a potential hardware or firmware glitch with this specific device as a rare case. I recommend proceeding with William's advice on this matter.

  • xcorrxcorr Montreal

    So I managed to flash the Ganglion with latest firmware, and indeed that fixed it so I can see my pulse now (I'm alive!). Screenshot:

    I do notice that it there are still some glitches that are associated with shifting baselines, so I'll take a look at the compression algorithm and see if I can fix - I think with the larger dynamic range of ECG compared to EEG it doesn't work as well.
    Here are the steps I used to flash the hardware (on Windows):

    • Install Arduino 1.8.15

    • Inside Arduino, in Tools > Library Manager

      • Install OpenBCI_Ganglion_library
      • Install OpenBCI_Wifi_master
    • In File > Additional Boards Manager URL, type:

    • In Tools > Board Manager

      • Install Simblee Boards
    • In C:\Users\%username%\AppData\Local\Arduino15\packages\Simblee\hardware\Simblee\1.1.4\variants\Simblee

      • Replace:
      #define SPI_INTERFACE        NRF_SPI0
      #define PIN_SPI_SS           (6u)
      #define PIN_SPI_MOSI         (5u)
      #define PIN_SPI_MISO         (3u)
      #define PIN_SPI_SCK          (4u)
      • With:
      #define SPI_INTERFACE        NRF_SPI0
      #define PIN_SPI_SS           (26u)
      #define PIN_SPI_MOSI         (18u)
      #define PIN_SPI_MISO         (15u)
      #define PIN_SPI_SCK          (16u)
    • Plug in FTDI basic

    • Install FTDI drivers

      • Download from here: https://ftdichip.com/drivers/vcp-drivers/
      • Windows > Device Manager > RT232 with a missing driver > right-click, update driver, point to zip
      • Again in device manager, same process for USB serial port
    • Open File > Examples > OpenBCI_Ganglion_Library > DefaultGanglion

    • Plug in the battery of Ganglion and turn on
    • Plug in the OpenBCI according to the upload guide

      (I couldn't find a 0.1 uF cap so I put two 0.2 in series)

    • Hit Upload

    • Connect to the board using the OpenBCI GUI and check everything works.
Sign In or Register to comment.