delay issue with OpenViBE in virtual machine / speller questions

jetjet U.S
edited June 10 in Cyton

Hello there,
I bought the Ultracortex "Mark IV" EEG Headset around 2 months ago, and have been using Cz (directly on the top of the headset), O1, and O2 (which are on the bottom back of the headset) channels on the headset in order to detect p300 signals with OpenVibe software.
While it has occurred to me that the signals show up as completely normal upon signal display inspection, there seems to be a problem with the timing of peaks of the signals. However, when I tap on the electrodes to receive a signal, I always see a peak.
I have an external battery pack on a holder connected to the Cyton board, and I believe all of the electrodes are in the right place. I have also replaced any jumper wires that may have seemed unusable.
I have speculated it to be a delay issue, so I changed the settings for my OpenVibe acquisition client to "let driver decide".
As of now the client shows that there is a 1-8 ms delay, but the actual delay of the peaks for the p300 signal epochs is much later than that (0.5-0.8 seconds). I am using an Ubuntu 16.04 VM to run the brain headset.
Are there any troubleshooting solutions I could do to see if the headset is actually picking up the correct brain waves; for example, if I blink or do a mind concentration activity how would I know the headset is picking that up correctly?

Comments

  • retiututretiutut Louisiana, USA
    edited June 4

    @jet I think you need to adjust the Serial Port latency on your Ubuntu machine. Cyton + Dongle communicates via Serial communications. You can lower the latency to 1ms.

    https://docs.openbci.com/docs/10Troubleshooting/FTDI_Fix_Linux

    Hope this helps,
    RW

  • wjcroftwjcroft Mount Shasta, CA

    Richard, thanks.

    @jet another comparison you can make, is with and without the VM involved. I'm assuming from what you said, that Ubuntu is the base OS, and you are running a Windows VM on top of that with OpenViBE.

    After ensuring that your latency is fixed, as Richard suggests, compare performance of the OpenBCI GUI on Ubuntu, to how it looks under Windows. If all the latency issues are handled, there should be no delays in either case. You may need to tweek the FTDI latency on both OSes.

    William

  • jetjet U.S
    edited June 10

    @retiutut
    I changed the serial port latency on the Ubuntu VM from 16 -> 1ms, but it didn't have much of a difference.

    @wjcroft
    I am actually running a patched version of OpenVibe on an Ubuntu VM with a Windows base OS.
    Even when training the classifier (in the p300 basic speller, not the xDAWN speller), the scenario gets 83% accuracy no matter what data is fed in; however, I printed out the outputs from the online scenario's classifier (target or nontarget) to a log file, and only two cases had target labels with all the rest being nontarget. So it's hard to understand why the classifier doesn't pick up on p300 signals.

    Here is the p300 CSV data for the online scenario:

    https://drive.google.com/file/d/1BMOQ1AZBp9Uxsyn_aRVwfvxgwcX1wwc-/view?usp=sharing

    Will running the scenarios with OV files be more beneficial than running them with CSV files?

    I am also considering running the xDAWN classifier over the basic p300 speller classifier. My current headset is only 8 channels--so I have changed the spatial filter config file so that the second setting value is 8:

    Will the classifier still perform as well with 16 channels as it does with 8?

    Thanks.

  • wjcroftwjcroft Mount Shasta, CA

    Best place to ask OpenViBE questions is their own forum. However if you look on there, I believe the speller is still not being supported.

    http://openvibe.inria.fr/forum/

    http://openvibe.inria.fr/forum/search.php?keywords=speller

    If you actually want a superior speller app, look into MindAffect. It is not using the relatively slow P300 speller algorithms, but instead (a much faster) cVEP, code based visual evoked potentials.

    https://mindaffect-bci.readthedocs.io/en/latest/

    If you are running a base Windows OS, I don't understand why you are using the Ubuntu VM on top of that. Just run the stock OpenViBE.

    Regards, William

  • wjcroftwjcroft Mount Shasta, CA

Sign In or Register to comment.