MacOS Catalina (10.15.6) usbserial not created [resolved]

Geo99M6ZGeo99M6Z Ohio, US
edited January 12 in Cyton

Hi -
I have a new dongle + cyton + daisy module and I cannot get it to work on my Mac. I tested the USB dongle on my wife's Windows computer and it connects just fine.
I have installed/reinstalled/removed - then - reinstalled FTDI drivers and I get nothing. No serial device is listed in the OpenBCI GUI. I also installed ftci-vcp via: "brew install --cask homebrew/cask-drivers/ftdi-vcp-driver" restarted and still nothing.
When I plug the dongle in, this is what I see within the System Information

FT231X USB UART:
Product ID: 0x6015
Vendor ID: 0x0403 (Future Technology Devices International Limited)
Version: 10.00
Serial Number: DM025858
Speed: Up to 12 Mb/s
Manufacturer: FTDI
Location ID: 0x14300000 / 5
Current Available (mA): 500
Current Required (mA): 90
Extra Operating Current (mA): 0

I am at a loss on trying to get this to work.

Comments

  • wjcroftwjcroft Mount Shasta, CA

    Hi, Geo,

    Just offhand, that method of using 'brew' to install, it is NOT what FTDI recommends. They show a dmg containing a pkg installer.

    https://www.ftdichip.com/Drivers/VCP.htm

    There could be interference between the drivers, Apple original, FTDI pkg installer, and brew version.

    William

  • Geo99M6ZGeo99M6Z Ohio, US

    I have installed the following:

    FTDIUSBSerialDriver_v2_4_4
    FTDIUSBSerialDriver_v2_4_2
    FTDIUSBSerialDriver_v2_3
    homebrew/cask-drivers/ftdi-vcp-driver (last installation)

    Each done by the following method:

    cd /Library/Extensions
    sudo rm -rf FTDIUSBSerialDriver.kext
    restart
    Install .dmg from above
    Open Settings --> Security & Privacy to see if it needed confirmation
    restart

    Just not sure why /dev/cu.usbserial-XXXXX isn't being created

  • wjcroftwjcroft Mount Shasta, CA

    So to clarify, when you plug the dongle into the Mac, ZERO /dev/xxxx new entries appear?

    But the dongle is showing in your System Information. And the dongle is indeed an FT231X model FTDI chip. Why did you do the brew install? I would suggest undoing that.

    I've seen issues with Catalina and kexts being locked down...

    https://www.google.com/search?q=catalina+kext
    https://www.google.com/search?q=catalina+kext+csrutil

    In one instance (non OpenBCI driver), for another product, I had to boot into recovery mode, turn off with csrutil the SIP, reboot, install, reboot turn back on the SIP, etc.

  • Geo99M6ZGeo99M6Z Ohio, US

    Yes that is true. Zero new entries appear.
    I was able to get a snapshot of the chipset with my phone:

    FTDI
    HYP1T.00
    FT231XQ
    1838-D

    I had not done the "csrutil disable, reboot, install, reboot, csrutil enable" yet.
    I just did that and the only thing that is different now is when I plug the dongle into the USB
    /dev/ttys001 appears to be written (timestamp) but I am still not able to see in OpenBCI GUI.

  • wjcroftwjcroft Mount Shasta, CA

    Hmm, ok, closer. Mentioning Richard @retiutut.

    It seems unlikely, but your macOS there may be using different /dev/ tty names than normal. I believe it is possible with the GUI to manually enter the tty name. Rather than letting it determine automatically.

    Perhaps your tty names differ because of the update history of your macOS.

  • wjcroftwjcroft Mount Shasta, CA

    Please ensure the brew stuff is not active or installed. You should just be using FTDI installer.

    Frankly I understood that most new macOS versions just recognize the dongle without even needing the FTDI driver. That is, the build in Apple driver is sufficient. But in your case, apparently not.

  • Geo99M6ZGeo99M6Z Ohio, US

    I removed the brew stuff early this morning.
    What is strange is that the AppleUSBFTDI.kext is missing. I have been searching most of the day to try and figure out how to install it. Maybe someone could "zip" it up and make it available for me then I will remove all the installed FTDI drivers. :wink:

    Not found in /System/Library/Extensions nor is it in /Library/Extensions.

    In January last year I did some Arduino ESP8266 development and I remember I had to do something to get the usbserial to work. Do I think I would have removed it completely when I had to get the ESP8266 to work last year; No. Could I have removed it; probably.

  • retiututretiutut Louisiana, USA

    The GUI looks for the product name for all serial ports. Try reinstalling the FTDI driver: https://www.ftdichip.com/Drivers/VCP.htm

    You should be using https://www.ftdichip.com/Drivers/VCP/MacOSX/FTDIUSBSerialDriver_v2_4_4.dmg, but I have seen https://www.ftdichip.com/Drivers/VCP/MacOSX/FTDIUSBSerialDriver_v2_2_18.dmg work on Catalina.

    If the kext file is missing, I'm not sure how it could work. Removing this file is a step in the process to adjust latency on Mac.
    https://docs.openbci.com/docs/10Troubleshooting/FTDI_Fix_Mac#step-2-remove-any-existing-ftdi-drivers--reboot

  • wjcroftwjcroft Mount Shasta, CA

    Richard, he says he has already installed the FTDI v2.4.4. But he is not getting the correct tty /dev/xxx showing up. He DOES get a /dev/ttys001 to appear. But not the normal /dev/cu.usbserial-XXXXX, as GUI expects.

    So could be, his macOS is screwy from previous installs of serial drivers. Can he manually specify the /dev/ttys001 that he does see? GUI buttons let you do that, right?

  • retiututretiutut Louisiana, USA
    edited January 8

    In 5.0.2, the only serial port options that show have a matching product name for the Cyton Dongle, which is the same on all OS ~ "FTDI UART 231X". Other serial ports will not show up.

    Also, BrainFlow needs to use the /dev/cu.usbserial-XXXXX port on Mac. It certainly wouldn't hurt to update to Catalina 10.15.7.

    FTDI v2.4.4 should work for all users on OS X Catalina, so maybe try manually removing the FTDI driver thoroughly and try installing again.

    If all else has failed, try FTDI 2.2.18 https://www.ftdichip.com/Drivers/VCP/MacOSX/FTDIUSBSerialDriver_v2_2_18.dmg. This worked once when debugging with another user.

  • retiututretiutut Louisiana, USA

    @Geo99M6Z Can you share the output of the following command in your Mac terminal? Make sure the dongle is plugged in.

    ls /dev/cu.*
    
  • Geo99M6ZGeo99M6Z Ohio, US

    Ok, I tried something different this time. Took the advice to re-install FTDI v2.4.4
    After the installation, I decided to follow these steps outlined here https://docs.openbci.com/docs/10Troubleshooting/FTDI_Fix_Mac#step-2-remove-any-existing-ftdi-drivers--reboot
    Entered recovery mode and entered the following commands:

    sudo nvram boot-args="kext-dev-mode=1"
    csrutil disable

    Restarted and decided to try OpenBCI GUI. It is currently working. I still need to csrutil enable to see if it will still work.
    Thanks all for the advice. Not quite sure after re-installing for the n-th time that it worked, well it somewhat has to do with the SIP configuration.

Sign In or Register to comment.