Cyton GUI output freezes with Daisy, but works fine without (8 channels)

edited December 2020 in OpenBCI_GUI

Hello,
In 2015 around I sponsored OPENBCI with kickstarter and bought the Cyton BCI with daisy.
Daisy came with soldering work.
So first I did somme eeg sampling with Cyton without daisy.
Years later (now) I started the soldering and afterwards I thought daisy was perfect for hooking on the Cyton.
Although 8 channels are fine with Cyton with daisy on board the channel display freezes an no data were sampled. (s. attachments)
could some one please explain what is wrong ?
I would be very glad to get your hints...
kind regards
merlin
(no magic at all :-)

1st file data with 8 channels
2nd file data with daisy
3rd log file (one session with Cyton following with daisy
4th picture of assembled Cyton with daisy

Comments

  • wjcroftwjcroft Mount Shasta, CA

    Hi Merlin,

    Since your Cyton from 2015 came with the old V1 firmware, have you upgraded the Cyton firmware to latest levels? Without upgrading, there are known compatibility issues with the current GUI and old firmware.

    Regards, William

  • thank you for your comment. I keep you informed as soon I am done.
    kind regards
    merlin

  • edited January 3

    Happy new year...
    I tried upgrading resp. sketching as described for upgrading for daisy:
    every trial ends with with "bad type cpu".
    where is the mistake ?
    thank you

    /Applications/Arduino.app/Contents/Java/arduino-builder -compile -logger=machine -hardware /Applications/Arduino.app/Contents/Java/hardware -hardware /Users/macbookpro/Library/Arduino15/packages -tools /Applications/Arduino.app/Contents/Java/tools-builder -tools /Applications/Arduino.app/Contents/Java/hardware/tools/avr -tools /Users/macbookpro/Library/Arduino15/packages -built-in-libraries /Applications/Arduino.app/Contents/Java/libraries -libraries /Users/macbookpro/Documents/Arduino/libraries/libraries/libraries -fqbn=chipKIT:pic32:openbci -vid-pid=0000_0000 -ide-version=10813 -build-path /var/folders/56/th2yrwf12mb0s9ltt7c1kpch0000gn/T/arduino_build_767801 -warnings=default -build-cache /var/folders/56/th2yrwf12mb0s9ltt7c1kpch0000gn/T/arduino_cache_38630 -prefs=build.warn_data_percentage=75 -prefs=runtime.tools.pic32prog.path=/Users/macbookpro/Library/Arduino15/packages/chipKIT/tools/pic32prog/v1.0.01-pic32gcc -prefs=runtime.tools.pic32prog-v1.0.01-pic32gcc.path=/Users/macbookpro/Library/Arduino15/packages/chipKIT/tools/pic32prog/v1.0.01-pic32gcc -prefs=runtime.tools.pic32-tools.path=/Users/macbookpro/Library/Arduino15/packages/chipKIT/tools/pic32-tools/4.8.3-pic32gcc -prefs=runtime.tools.pic32-tools-4.8.3-pic32gcc.path=/Users/macbookpro/Library/Arduino15/packages/chipKIT/tools/pic32-tools/4.8.3-pic32gcc -verbose /Users/macbookpro/Documents/Arduino/libraries/libraries/OpenBCI_32bit_16channel-master/OpenBCI_32bit_16chan/OpenBCI_32bit_16chan.ino

    Using board 'openbci' from platform in folder: /Users/macbookpro/Library/Arduino15/packages/chipKIT/hardware/pic32/1.0.1
    Using core 'pic32' from platform in folder: /Users/macbookpro/Library/Arduino15/packages/chipKIT/hardware/pic32/1.0.1
    Detecting libraries used...
    /Users/macbookpro/Library/Arduino15/packages/chipKIT/tools/pic32-tools/4.8.3-pic32gcc/bin/pic32-g++ -c -g -O2 -w -mno-smart-io -fno-exceptions -ffunction-sections -fdata-sections -mdebugger -Wcast-align -fno-short-double -ftoplevel-reorder -w -x c++ -E -CC -mprocessor=32MX250F128B -DF_CPU=40000000L -DARDUINO=10813 -D_BOARD_DP32_ -DARDUINO_ARCH_PIC32 -DMPIDEVER=16777998 -DMPIDE=150 -DIDE=Arduino -G1024 -D_USE_USB_FOR_SERIAL_ -I/var/folders/56/th2yrwf12mb0s9ltt7c1kpch0000gn/T/arduino_build_767801/sketch -I/Users/macbookpro/Library/Arduino15/packages/chipKIT/hardware/pic32/1.0.1/cores/pic32 -I/Users/macbookpro/Library/Arduino15/packages/chipKIT/hardware/pic32/1.0.1/variants/OpenBCI /var/folders/56/th2yrwf12mb0s9ltt7c1kpch0000gn/T/arduino_build_767801/sketch/OpenBCI_32bit_16chan.ino.cpp -o /dev/null -DARDUINO_LIB_DISCOVERY_PHASE
    fork/exec /Users/macbookpro/Library/Arduino15/packages/chipKIT/tools/pic32-tools/4.8.3-pic32gcc/bin/pic32-g++: bad CPU type in executable

  • wjcroftwjcroft Mount Shasta, CA

    Merlin, thanks for your efforts. Take look at this thread, which I found using the Google Advanced Search button in the upper right column (on "bad CPU type"):

    https://openbci.com/forum/index.php?p=/discussion/2531/upgrading-2014-cyton-board-not-a-macos-driver-issue

    Apparently the issue you are seeing from the PIC32 gcc compiler, is that it is built for 32 bit MacOS. As of Catalina, 32 bit apps are no longer supported. As the fastest workaround, I recommend you try to locate a Windows machine and build there. All versions of Windows can run both 32 and 64 bit apps.

    Mentioning Richard @retiutut, and Shirley @Shirley; should we place a warning / workaround in the docs, mentioning the macOS 32/64 bit compiler issue? Would also be great if there WAS a 64 bit gcc someplace. Seems possible since Microchip still supports PIC32.

    https://www.google.com/search?q=pic32+mac+gcc+64+bit
    https://www.microchip.com/forums/m1111990.aspx
    "64bit compiler executables for MacOS 10.15 Catalina"

    Regards, William

  • edited January 3

    if you really wanted a mac gcc build, you could try to build a 64-bit gcc for PIC32 from the source code (I have not tried this):
    https://github.com/ccompiler4pic32/pic32-gcc

  • wjcroftwjcroft Mount Shasta, CA

    Bill and Merlin, thanks.

    If @merlin wanted one other avenue for his present Mac, one could install the free VirtualBox software (virtual machine emulator),

    https://www.virtualbox.org/

    Then install a free image of Windows 10,

    https://developer.microsoft.com/en-us/microsoft-edge/tools/vms/

    Then build using the Windows instructions from OpenBCI.

  • I was successfull compiling sketching and flashing with my 1 year old macbook.
    I flashed with chipkit 1.3.1 and openbci including daisy.

    Maximum sind 32768 Bytes.
    Programmer for Microchip PIC32 microcontrollers, Version 2.1.24
        Copyright: (C) 2011-2015 Serge Vakulenko
          Adapter: STK500v2 Bootloader
    Program area: 1d000000-1d1fffff
        Processor: Bootloader

    finally: new sketch old problem:
    8 channels ok
    freezing with 16 channels:
    Console Log Started at Local Time: 2021-01-05_18-11-27
    Screen Resolution: 1440 X 900
    Operating System: Mac
    Welcome to the Processing-based OpenBCI GUI!
    For more information, please visit: https://openbci.github.io/Documentation/docs/06Software/01-OpenBCISoftware/GUIDocs
    OpenBCI_GUI::Setup: GUI v5 Sample Data exists in Documents folder.
    ControlP5 2.3.1 infos, comments, questions at http://www.sojamo.de/libraries/controlP5
    TopNav: Internet Connection Successful
    Local Version: v5.0.2, Latest Version: v5.0.2
    GUI is up to date!
    The file "/Users/admin/Documents/OpenBCI_GUI/Settings/UserPlaybackHistory.json" is missing or inaccessible, make sure the URL is valid or that the file has been added to your sketch and is readable.
    OpenBCI_GUI::Control Panel: Playback history file not found or other error.
    null
    OpenBCI_GUI::Setup: Setup is complete!
    sourceList: click!
    Channel count set to 8
    ControlPanel: Found Cyton Dongle on COM port: /dev/cu.usbserial-DN0094JK
    cytonDongleList: click!
    [DEFAULT]: ControlPanel: Selected OpenBCI Port /dev/cu.usbserial-DN0094JK
    cytonDongleList: click!
    [DEFAULT]: ControlPanel: Selected OpenBCI Port /dev/cu.usbserial-DN0094JK
    Channel count set to 16
    [DEFAULT]: OpenBCI microSD Setting = Do not write to SD...
    [DEFAULT]: Attempting to Start Session...
    initButtonPressed: Calling initSystem() after next draw()
    OpenBCI_GUI: Start session. Calling initSystem().

    =================================================

    ||             INITIALIZING SYSTEM             ||

    Channel count set to 16
    InitSettings: Saving Default Settings to file!
    SessionSettings: 3 active widgets saved!
    [SUCCESS]: Session started!
    [DEFAULT]: openBCI_GUI: startButton was pressed. Starting data transfer, wait a few seconds.
    Brainflow start streaming
    [DEFAULT]: Data stream started.
    OpenBCI_GUI: openNewLogFile: opened ODF output file: /Users/admin/Documents/OpenBCI_GUI/Recordings/OpenBCISession_2021-01-05_18-11-29/OpenBCI-RAW-2021-01-05_18-12-37.txt
    [DEFAULT]: openBCI_GUI: stopButton was pressed. Stopping data transfer, wait a few seconds.
    Brainflow stop streaming
    [DEFAULT]: Data stream stopped.
    ConsoleLog: Copying console log to clipboard!

    No data were streamed

    what can I do...
    is it a soldering problem?
    thank you for your assistance.

  • wjcroftwjcroft Mount Shasta, CA

    Your 2015 Cyton almost certainly had the V1 firmware. Both in the PIC32 Cyton mainboard and the RFduinos (dongle and mainboard) that handle the radio communications. Did you update ALL THREE of this chips firmware?

    https://github.com/OpenBCI/OpenBCI_Cyton_Library/blob/master/UPGRADE_GUIDE.md
    https://docs.openbci.com/docs/02Cyton/CytonRadios
    https://docs.openbci.com/docs/02Cyton/CytonProgram

    Beyond the old firmware issue, you may also have issues with the connection pins between Cyton and Daisy. Especially since you soldered them yourself.

Sign In or Register to comment.