/dev/tty.usb serial or /dev/cu.usb serial ?

KCDTylerKCDTyler Melbourne, Australia
Hi all,

Just a minor confusion I am keen to get to the bottom of:

There seem to be two serial port options on the GUI, /dev/tty.usbserial DQ00 etc and /dev/cu.usbserial. DQOO etc

I had been using the /dev/tty post just fine, but have run into some other issues related to a recent firmware upgrade and am just wondering if it has anything to do with there two serial port options. 

Which serial port would be the correct one to use when streaming? and what is the difference between these two serial port options?

Thanks,

Comments

  • wjcroftwjcroft Mount Shasta, CA
    edited January 10
    KCD, hi.
    The link below has some discussion on the rational for cu vs tty /dev entries.

    https://stackoverflow.com/questions/37688257/choosing-between-dev-tty-usbserial-vs-dev-cu-usbserial

    Generally, the best approach is to use the same /dev string that the GUI chooses automatically, see the following posts.

    William
  • edited January 10

    Hi William,

    I'm trying to run the dino chrome game in the docs link here, and it looks like I'm facing an issue with the serial ports
    (ie I'm running in the command line, python chrome_dino_v1.py --serial-port /dev/ttyUSB0 --board-id 0)

    I tried double-checking the serial port, and realized that in the "serial/com port" section while opening the GUI, it only gives me one option, /dev/cu.usbserial-DM03H6HW; however, the data seems to be streaming fine when I start the session.

    Additionally, I tried finding the port manually using ls /dev/tty.*, and entering the full response (/dev/tty.usbserial-DM03H6HW) in the script above like so: python chrome_dino_v1.py --serial-port /dev/tty.usbserial-DM03H6HW --board-id 0.

    Am I missing something or need to adjust the serial port language for the script to understand? Appreciate the help on this!

  • wjcroftwjcroft Mount Shasta, CA
    edited January 10

    Did you try using the same /dev/cu.usbserial-DM03H6HWstring (in your --serial-port argument) that the GUI is using? The /dev/ttyUSB0 format is Linux.

  • edited January 10

    Hi William, thanks, that allowed the program to run.

    I was able to successfully follow the instructions / calibrate within the terminal, but still having some trouble getting the muscle flexes to trigger the jump in the game in browser -- will look into the code and see if I can tweak some things in my text editor to fix the issue. (might have something to do with running the code on OS X vs Linux)

Sign In or Register to comment.