Dongle USB not responding to computer's Device Descriptor Request

Hi, when I plug the BT dongle that I received from openbci into my Win10 laptop, a message appears saying it isn't recognized, and in the Device Manager section for USB controllers I see:  "Unknown USB Device (Device Descriptor Request Failed)"

I bought the Ganglion & dongle in early February 2017, but I was busy and I only began trying to use it last week.  Since that time I've tried many dozens of times with two Win7 laptops, one Win7 desktop, one Win10 laptop, and one Win10 desktop.  There have been a few times that it was recognized for maybe up to 30 seconds, then it reverted to failed-mode, I believe without action on my part.  I've tried it in various USB ports:  a High Speed ("USB 2.0"), several SuperSpeed (USB3.0), and a couple SuperSpeed with the power capability thing. 

I'm not completely sure but it seems to me that other Forum posts are a little different than my experience.  When it's in this state, I don't believe running zadig is meangful.  In zadig, the "From" driver field is blank.  And I'm not to the point where I could try to pair, or interact with the GUI.

A colleague or I have gone through all the steps at except for "Method 6: Remove Power Supply to Fix USB Device Not Recognized".  I started also going through but my Win10 laptop disallowed me from moving usbstor.inf.

I just ordered a CSR 4.0 BT dongle from amazon, I hope it's CSR-legit, etc., anyway it's worth a try, I should have it Saturday..

Any other ideas, or info I could explain, or experiments I could run?  Data I could report back here, etc.?  Thanks!

               -- Bruce P.


  • wjcroftwjcroft Mount Shasta, CA
    Bruce, it sounds like you could possibly have gotten a defective dongle originally in February. Sorry for the inconvenience and time investigating and troubleshooting. Can you send a copy of your post here in this thread to contact at ? It should be possible to get you a working dongle.

    Also post here on this thread your experience with the Amazon dongle, just for reference.

    Regards, William

  • Thanks William, it seems you were right, that dongle seems defective, intermittent, only rarely works.  Upon trying the one I then got on amazon, it immediately worked and hasn't quit since, after many usages for a few weeks.  I'm so relieved.  It has an amazon "ASIN" number of B01IM8YKPW, it's sold by "Daykit" and on the amazon webpage it's being called "DayKit Mini USB Bluetooth CSR 4.0 Dual Mode Adapter Dongle for Windows 10 8 7 Vista XP 32/64 Bit Raspberry Pi Linux Black", $6.89, amazon prime.  To me the size/shape/coloring/marking look identical to the intermittent one that I received from OpenBCI.

Sign In or Register to comment.