Cannot find Ganglion on win10 using provided CSR dongle

First off, I know this seems like a duplicate post since there are 2 other discussions regarding the same. However, I have followed all the instructions and help given in the previous two discussions, namely to use the provided CSR 4.0 dongle, first install the CSR harmony suite and then use the Zadig tool to override the drivers for the dongle. I have tried, as mentioned, to use different USB ports (all 2.0) available on my PC. Unfortunately, none of this seems to help and my device does not show up on the BLE devices section of the openBCI GUI. The blue light on the Ganglion blinks. I assumed the Ganglion would be discoverable, but can't seem to find it when searching for available BLE devices from my android phone/tablet. Any help? Spent the better part of 2 days on this. I'm running Win10 x64

Thanks in advance,


  • Alternatively, is it possible to sample raw data from the board serial pins? If the BLE module on the board is faulty, I'd be open to trying a wired method 
  • wyan868wyan868 California
    I am thinking about the same thing for a different reason: if used in an operating room, Bluetooth communication might be affected seriously by the high-frequency electric knife. Does anyone have the experience of using OpenBCI boards in an operating room where high-frequency electric knife is used?
  • wjcroftwjcroft Mount Shasta, CA
    No you cannot use a direct wired connection to the board without careful optical or other isolation techniques. This has been done for Cyton using a USB isolator, see relevant threads. Not applicable for Ganglion unfortunately.

    Marc, can you try installing on a completely different laptop?


  • Hi @wjcroft,
    I tried on a different laptop (win10) but I didn't get around to installing the Visual Studio package(it's huge). I'm currently re-installing the Visual Studio package on my main PC (incase I forgot something the first time) and will then install python + nodejs + noble. I'm actually going through all the steps I read in the previous thread again just to make sure.
    I'm not in possession of a MacOS device, though I did try running the GUI as a processing sketch on Lubuntu 14.04. No success, although I didn't install any bluetooth driver so that attempt felt half-hearted. 
    I'll get back to you once I've tried on a different Win10 machine following all the above steps. Is there any alternative to the Visual Studio install? Since noble uses just the C++ compiler, it seems like a waste of time installing the whole package. Is it 100% necessary?
    Also, is there any method to troubleshoot the discovery of the Ganglion board? To check whether the Simblee module is functioning correctly...?

    Thanks and regards,
  • wjcroftwjcroft Mount Shasta, CA
    Mentioning AJ Keller @pushtheworld. AJ, is there a Github issue folder where this should be logged? I'm not clear which repo.

    Why are people needing to build noble from scratch using Visual Studio? Isn't there a pre-compiled version when they install the Ganglion node package? These visual studio suggestions are over on the other thread,

  • Hi @wjcroft,
    I just got done reinstalling the Visual Studio packages along with all the other proposed solutions. I've almost confirmed my suspicions that it has something to do with the board. I've tried it on my dad's PC (win10) too, to no avail. Is there any debugging method I can follow, or if not, request for an RMA?
  • wjcroftwjcroft Mount Shasta, CA
    Send an email to contact at .

    I believe that a Ganglion hardware troubleshooting guide would be very helpful for those encountering connection difficulties. This was easier in Cyton as you could just use a terminal emulator on the COM port and type '?' and get some response.

    Requiring OpenBCI users to deal with Visual Studio installation and the complex steps outlined on the other thread seems hugely daunting and not user friendly.

    Mentioning Joel @biomurph, @Conor, AJ Keller @pushtheworld.
  • @marcm this sounds very frustrating!

    "but can't seem to find it when searching for available BLE devices from my android phone/tablet."

    this is the most concerning to me and does not seem normal. Maybe it's a bad board?

    You should still be able to find the device using your BLE that comes with your computer. I use light blu on mac. 

    @wjcroft i think visual studio is required because to compile C++ code on windows. Does that make sense?

    I would for sure email contact at like @wjcroft said! Let's get you up and running!

  • wjcroftwjcroft Mount Shasta, CA
    AJ, couldn't OpenBCI provide pre-compiled C++ modules (is that the noble package?) with our installer?

    A short note (even here) on what troubleshooting steps you personally take in such situations, would be helpfjul. That post could eventually become a tutorial on the docs site.


  • @pushtheworld I suspected a bad simblee uController but thought maybe the device wasn't publicly discoverable.
    I've contacted them, hopefully I get a replacement soon. Thanks!
  • @marcm good to hear you reached out to them! so sorry that happened to you! that's a bummer :(
  • biomurphbiomurph Brooklyn, NY
    edited March 2017
    Simblee is not readily discoverable with BLE on a computer or phone/tablet.

    On your android phone, you can use nRF toolkit
    This tool will be able to find and connect to the Ganglion board.
    Please try that to verify that the Ganglion is discoverable and that you can connect to it to read it's services. If you can, then the problem is with the BLE Dongle and or drivers.
  • Hi @biomurph,
    I tried the app you linked to as well as the nRF Connect app provided here
    The board fails to show up on either of the apps' available BLE devices list.
    I have linked two pictures to show the same, using: nRF Connect  nRF Toolbox
Sign In or Register to comment.