Community /

[RESOLVED] Help With Debugging SD Card Writing

Trying to write to SD Card – followed tutorial.. but still struggling.

A.  Running GUI through processing – can see that SD command is sent when I select a time period to record for (via Console)

B.  Begin acquiring data – can see data come in via GUI.  Let system run for a few minutes.

C.  Stop streaming, turn off Cyton, remove SD card and check for data file using PC.  No data file present.

Uncertain if I missed a step somewhere – but any help is appreciated.

*** Resolved **** here’s a couple of hints that may help other people out:

  1.  This ended up being a formatting problem (I followed windows instructions in OpenBCI tutorial – NOTE these probably need to be updated given that the SD people have released a new formatter – see below) – the only clue I finally got is when I sent a text command via m,start,14sec,;\n.  The device responded with that it could not find a FAT16/FAT32 formatted SD card (very helpful error message – thank you who ever did that!).  SIDE NOTE that may be helpful: To send send commands to the cyton via electron hub using windows (1) download cygwin (make sure you get the 32 bit version, even if you have a 64 bit machine – else telnet will not be available) (2) select the inetutils package so that telnet will be loaded onto your machine.  After that, telnet localhost 10996 from a Cygwin console window (if you have not used Cygwin, double click on the Cygwin window on your desktop after installing) – telnet will then allow you to send commands via electron hub running on localhost.
  2. I then reformatted the card using the suggested link in OpenBCI tutorial ( and focused a bit more this time)… Important note the link will download version 5 of the software (different windows from the version in the OpenBCI tutorial).  This, for me, turned out to be the root of the problem – version 5 formats the SD to exFAT as opposed to FAT32 (with no options to change)…  So, then I turned to the MAC.  I tried to format using the MAC and FAT32 (instructions in tutorial); however, the MAC forced me to make a decision between GUID and MBR – I chose wrongly as things still would not work…  However (as an important note) this time – the cyton would not complain… it would act as if it was writing data during acquisition – but still no data on the SD Card.  Console window on the Processing IDE also offered no clues.
  3. Final solution:  Used the SD card program to repartition/reformat the drive to exFat (clean up after Mac).   Moved the card to a Linux machine, removed the partition using fdisk (wrote the new partition with w), and added a new partition of type FAT32 (W-95 LBA).  Formatted the card with mkfs.vfat -F32 -v /dev/sd??  where ?? = c1 in my case… For more information – the SD card is a 64 GB SanDisk Ultra.

A couple of other (clarifying) notes in terms of how writing to SD card works with GUI…

  1. I ran the GUI from the Processing IDE.  Selected write the SD card in the drop down and the 5 minute option – for testing.
  2. Then started taking data as normal (i.e. if I was not writing to SD card … click on start streaming) – and the channels start reporting via the GUI
  3. Stopped after a couple of minutes, closed the GUI, turned off the Cyton, removed the card, put the SD card into my USB/SD card reader, loaded the reader into my windows machine, and located the test file.

Have not fully tested everything w.r.t speed, etc – but now I have data.

 

Leave a Reply